Building Qt Jambi from source on Ubuntu 11.04


Posted by Akos Kemives
at 2011-05-28 08:37

To build it from sources you have to install the following dependencies:
ant, java (either the sun-java6-jre or the openjdk one), qt development libraries.

If you don't know what I'm talking about paste the following line to your terminal:

sudo apt-get install default-jdk default-jre ant libqt4-dev libqtwebkit-dev libphonon-dev phonon-backed-gstreamer

Change the paths in your buildpath.properties as it is described for every option.
Modify qtjambi.java.library.path according to your libstdc++.so.6 location.
In my case it is:

akoskm@turing:~/qtjambi/akoskm-unittests$ dpkg-query -S libstdc++.so.6
libstdc++6: /usr/lib/i386-linux-gnu/libstdc++.so.6.0.14
libstdc++6: */usr/lib/i386-linux-gnu*/libstdc++.so.6

after replacing the default path it looks like:
qtjambi.java.library.path = /usr/lib/i386-linux-gnu
Build it:

ant all

Happy hacking !

The packages in ppa should arrive soon, stay tunned.


← Back to blog
blog comments powered by Disqus
← Back to blog
This page was updated at 17.05.2016